Archive for May, 2016

Upgrade MariaDB 5.5.x to 10.0.x on Slackware 14.1 x64

May 15th, 2016 No comments


Update for Slackware x64: latest version of MariaDB 10.0. This package was build on a Slackware 14.1 system. To build this package succesfully on a 14.1 system, you also need to install the jemalloc package.



How to upgrade from MariaDB 5.5.x to MariaDB 10.0.x

1. Start by downloading the 2 packages above.
2. Transfer these packages to the server you want to upgrade.
3. First install the jemalloc package:

installpkg jemalloc-3.6.0-x86_64-1.txz

4. Stop the running mysqld service:

/etc/rc.d/rc.mysqld stop

5. backup ALL your databases (make a copy of the entire /var/lib/mysql directory).

cp -a /var/lib/mysql/ /var/lib/mysql-BACKUP

6. Uninstall the MariaDB 5.5.x package (use removepkg or pkgtool).
7. Install the new MariaDB 10.0.25 package:

installpkg mariadb-10.0.25-x86_64-1.txz

8. Make sure /etc/rc.d/rc.mysqld is updated (overwrite the old rc.mysqld with
9. Start the mysqld service:

/etc/rc.d/rc.mysqld start

10. Check if mysqld is running now:

ps aux | grep mysql

11. Run mysql_secure_installation. Maybe this is not really necessary, but it doesn’t hurt to start clean. While you’re at it, you can set a new mysql root password here as well.
12. Run mysql_upgrade (MUST DO):

mysql_upgrade -u root -p

10. Restart the mysql service again (just to be sure).

/etc/rc.d/rc.mysqld restart

11. Now go check your DB’s and applications.


Enjoy 🙂


Categories: mariadb, slackpkg, slackware Views: 269